Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 55

Thread: Wii-Clip Problem

  1. #21
    Junior Member
    Join Date
    Feb 2008
    Location
    Yaphank, NY
    Posts
    113
    Thanks
    0
    Thanked 1 Time in 1 Post
    Once you get your shipping info. and tracking info. from them that is was shipped by fed-ex, it took only 2 days after that to recieve my package....The shipping is really fast....I spoke to them the other day and they said they were overwheled with orders and didn't think that they would recieve this many orders and that things were a lil bit hectic right now....They are trying to fill orders as quick as possible...Drop them an email and ask if they have any idea of when it will be shipped out....Their customer service is great and are quick to get back to you with an answer...

  2. #22
    Junior Member
    Join Date
    Apr 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    no luck

    I ordered a pre-soldered d2ckey wii-clip from techsick and tried installing a couple days ago... and NOTHING as well. regular games would work but no backups. The led lights on the chip would come on when I turned the wii on but when I put in a backup no led lights or anything. The 1st time I put it on I made sure it was on tight and flush but it didn't work. I've tried re-setting it about 4 times now and it never worked and in the process there is now a little rip in the ribbon so I doubt it will work for sure now.
    I've emailed techsick about getting a replacement, haven't heard anything back yet but will let you know.

  3. #23
    Junior Member
    Join Date
    Apr 2008
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by mnguyen36 View Post
    I bought mine on 03/21/08 and emailed twice still no response and it also says processing all we can do is wait
    I ordere mine on 03/31/08 Di you received yours. Caus my order is still to pending. I tried to contact them two time but i got no answer

  4. #24
    Junior Member
    Join Date
    Feb 2008
    Location
    Yaphank, NY
    Posts
    113
    Thanks
    0
    Thanked 1 Time in 1 Post
    And you guys are def. facing the chip in the right direction correct....The lil rubber square should cover the chip on the wii, with the D2Cpro(mod chip) covering the hole on the wii dvd drive(facing middle). I'm telling you that I have done 3 so far and they all worked....Never on the first try but I got them to work. They are very tempremental. I would suggest leaving the wii apart untill you get the chip sitting right. Let me know if there is anything else I can help or answer for you guys....

  5. #25
    New Member
    Join Date
    Mar 2008
    Posts
    47
    Thanks
    7
    Thanked 3 Times in 1 Post
    The website says that they are out of stock at the moment. They will stop allowing people to make pre-orders and try to get in all of your orders by this week.

  6. #26
    Junior Member
    Join Date
    Apr 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    smokin,

    yes, I was putting it in the correct direction... I'm waiting for a new one to be shipped but I have my wii left taken apart to test it out.

    Did you push it down hard when installing it?

    Also, when you took it off to re-set it, how did you take it off? I just pulled hard on mine but it ends up breaking the ribbon. I thought about sticking something under and prying each side up, but I didn't want to ruin the board.

    Thanks.

  7. #27
    Junior Member
    Join Date
    Feb 2008
    Location
    Yaphank, NY
    Posts
    113
    Thanks
    0
    Thanked 1 Time in 1 Post
    Yes I did push it down pretty firm...Just look around the sides and make sure that it is flush down on all sides and that none of the solder points around the D2C chip on the wii are showing. As for pulling it off, I just grab the black piece that covers the chip and give a good pull on it....Do not pull it off from anywhere else but that black rubber piece.....

    Mine and the 2 others I did are still going strong....All games have worked so far and have not had a problem playing any games online either....

  8. #28
    Junior Member wakra's Avatar
    Join Date
    Apr 2008
    Posts
    24
    Thanks
    0
    Thanked 0 Times in 0 Posts
    is your drive d2c

  9. #29
    Junior Member
    Join Date
    Apr 2008
    Posts
    111
    Thanks
    0
    Thanked 0 Times in 0 Posts
    the D2Pro actaully is the most expensive out of the 3 chips so i highly doubt it teh copy version the pro howerver is about same with teh key

  10. #30
    Junior Member
    Join Date
    Feb 2008
    Location
    Yaphank, NY
    Posts
    113
    Thanks
    0
    Thanked 1 Time in 1 Post
    Yes it is D2C.....

Page 3 of 6 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •