Results 1 to 6 of 6

Thread: Buy - NTSC wii games in Adelaide, Australia

  1. #1
    New Member
    Join Date
    Apr 2011
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Buy - NTSC wii games in Adelaide, Australia

    I have a USA Wii and I've moved to Adelaide, SA, Australia. Does anyone know where I can get ntsc games in Adelaide?

  2. #2
    Retired Staffer bmarlo's Avatar
    Join Date
    Nov 2009
    Location
    Sydney,Australia
    Posts
    5,952
    Thanks
    978
    Thanked 1,706 Times in 1,318 Posts
    Blog Entries
    4
    If you softmod using the softmod any wii guide, and install a USB Loader and run your Original games from a HDD,
    You can play out of region games! Just click on the "useful links" spoiler in my signature for the guide.

    You might also want to introduce yourself to the community HERE!



  3. #3
    New Member
    Join Date
    Apr 2011
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by bmarlo View Post
    If you softmod using the softmod any wii guide, and install a USB Loader and run your Original games from a HDD,
    You can play out of region games! Just click on the "useful links" spoiler in my signature for the guide.

    You might also want to introduce yourself to the community HERE!
    I've read the guide. I have a 4.3u firmware so i need one of the games listed in the guide. I checked ebay and can buy one from the USA. I was wondering if it was possible to buy one locally.

  4. #4
    Retired Staffer bmarlo's Avatar
    Join Date
    Nov 2009
    Location
    Sydney,Australia
    Posts
    5,952
    Thanks
    978
    Thanked 1,706 Times in 1,318 Posts
    Blog Entries
    4
    No..I'd say ebay your best bet.



  5. #5
    Member
    WiiHacks Staff
    VWA
    Moderator
    Only Site Donators Can PM Staff
    playerkp420's Avatar
    Join Date
    Jan 2010
    Posts
    2,179
    Thanks
    223
    Thanked 492 Times in 429 Posts
    I noticed in your introduce yourself thread you said you had 3.4. Was that a misprint? With 3.4 you don't need a game exploit.

  6. #6
    New Member
    Join Date
    Apr 2011
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yeah, that should say 4.3u not 3.4u.

    Quote Originally Posted by playerkp420 View Post
    I noticed in your introduce yourself thread you said you had 3.4. Was that a misprint? With 3.4 you don't need a game exploit.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •