Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Help my wii has a black screen when u turn it on!!!

  1. #1
    Banned
    Join Date
    Oct 2010
    Posts
    42
    Thanks
    14
    Thanked 0 Times in 0 Posts

    Help my wii has a black screen when u turn it on!!!

    Help my wii has a black screen when u turn it on. it sounds like its trying to read a disk but nothing in it. it turns on from the wiimote. i have bootmii boot2 installed. and have nand.bin and keys.bin files but they dont work when u try to restore the wii. i tryed bootmii key fix it doesnt work ether. cuz it still sayed "dump from another wii". when i made it on that wii cuz it my only wii! i uninstalled ios249 when dis happend and now it has a black screen. the wii is on version 4.2u and there no modchips installed. it has homebrew channal but i cant get on it cuz my wii has a black screen. plz help me.

  2. #2
    Junior Member streamlinehd's Avatar
    Join Date
    Mar 2010
    Location
    East Coast, USA
    Posts
    1,369
    Thanks
    114
    Thanked 557 Times in 377 Posts
    Blog Entries
    3
    What did you do (if anything) to cause the black screen? You are in good shape seeing as you have boot2 Bootmii so relax, this issue can be fixed.

    FYI - Uninstalling IOS249 won't give you a black screen. What else did you do?
    Cogita ante salis
    If you're happy with the help I provided, don't forget to hit my thanks button


  3. #3
    Banned
    Join Date
    Oct 2010
    Posts
    42
    Thanks
    14
    Thanked 0 Times in 0 Posts
    so what should i do??????????????

    thx for ur posts

  4. #4
    Junior Member streamlinehd's Avatar
    Join Date
    Mar 2010
    Location
    East Coast, USA
    Posts
    1,369
    Thanks
    114
    Thanked 557 Times in 377 Posts
    Blog Entries
    3
    If you don't have any other details for me, I'll need you to use a savemii or savemiifrii and tell me if you can access recovery mode. I'll let you know what to do from there.
    Cogita ante salis
    If you're happy with the help I provided, don't forget to hit my thanks button


  5. #5
    Banned
    Join Date
    Oct 2010
    Posts
    42
    Thanks
    14
    Thanked 0 Times in 0 Posts
    i dont have those installed im a noob so dont know alot of stuff about wii hacking

  6. #6
    Junior Member streamlinehd's Avatar
    Join Date
    Mar 2010
    Location
    East Coast, USA
    Posts
    1,369
    Thanks
    114
    Thanked 557 Times in 377 Posts
    Blog Entries
    3
    Make a savemiifrii with a game cube controller see this post for info - Make savemiifrii
    Cogita ante salis
    If you're happy with the help I provided, don't forget to hit my thanks button


  7. #7
    Retired WiiHacks Staff Krafter's Avatar
    Join Date
    Dec 2009
    Posts
    4,425
    Thanks
    460
    Thanked 1,090 Times in 857 Posts
    Blog Entries
    5

  8. #8
    Junior Member
    Join Date
    Dec 2009
    Location
    England
    Posts
    1,304
    Thanks
    7
    Thanked 320 Times in 240 Posts
    Blog Entries
    2
    Doesnt bootmii give that error when you have a different boot2 version?

    I.e. you took the nand backup when on sm4.1 or lower, then updated to 4.2 which had a boot2v4 update, then your nand restore will complain.

    I ran into this briefly recently, but didnt have chance to test further.


    also, i dont see why you need to savemiifrii into recovery mode... just use cb2

  9. #9
    Junior Member streamlinehd's Avatar
    Join Date
    Mar 2010
    Location
    East Coast, USA
    Posts
    1,369
    Thanks
    114
    Thanked 557 Times in 377 Posts
    Blog Entries
    3
    Doesnt bootmii give that error when you have a different boot2 version?

    I.e. you took the nand backup when on sm4.1 or lower, then updated to 4.2 which had a boot2v4 update, then your nand restore will complain.
    Yes, Bootmii does give that error if the boot2 version doesn't match the boot2 version at the time the backup was made. It can be edited with a hex editor.

    For example:
    In the NAND dump - starting @ offset 21000248 and ending @ offset 2100025f needs to read:
    (03 00 00 00 00 00 00 03 03 03 04 00 00 00 00 00 00 04 04 04 00 00 00 00) for boot2 v4.

    and in the Keys.bin starting @ offset 00000248 and ending @ offset 0000025f the same. This should trick bootmii into thinking the boot2 version was v4 when the original dump was made.

    also, i dont see why you need to savemiifrii into recovery mode... just use cb2
    As you know, what the OP has explained shouldn't have caused a full brick so he should be able to access recovery mode. If he can't access recovery mode and re-installation of SM doesn't work I would at least know it might be a wi-fi module that's the issue. I wasn't able to give the CB2 option at the time because I was short on time and figured I would have a status on recovery mode by now. I will give a CB2 fix in a minute since it won't hurt to give it a try either way.

    EDIT:

    @OP

    Try this:

    Download MMM_FIX_4.1U.zip
    Extract contents to freshly formatted SD card
    Insert SD card in Wii and power On
    MMM Starts
    Choose Wad Manager
    Choose to install all wads (press 1)
    Make sure everything installs successfully

    Install Priiloader prior to exiting MMM
    Choose App Manager -> Priiloader and the installer will start.
    Follow Instructions to install Priiloader and then exit to SM.
    Fixed
    Last edited by streamlinehd; 11-02-2010 at 03:20 PM.
    Cogita ante salis
    If you're happy with the help I provided, don't forget to hit my thanks button


  10. #10
    Banned
    Join Date
    Oct 2010
    Posts
    42
    Thanks
    14
    Thanked 0 Times in 0 Posts
    so is that all i got to do to fix my wii? and do i have to have gamecube controller? also i have 4.2u installed
    Last edited by newguy224; 11-02-2010 at 04:02 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •