Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Help! Wii locked up, and now bricked?

  1. #1
    New Member
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Help! Wii locked up, and now bricked?

    I have a Wii with 4.2U. It is more than one year old and I'm in the Philippines where Nintendo don't market their products, so all Wiis are 'grey' imports. Getting any support from Nintendo would seem to be rather difficult.

    My Wii has always worked reasonably well but does, occasionally, lock up while playing a game. About a month ago, using guidance from this (and other) forums, I installed Homebrew and other gubbins with USB Loader GX. Since then I have copied all my games discs to a hard drive in a USB enclosure, making the Wii much more usable (I should have done this a long time ago.

    Anyway, this morning the kids were using the Wii and it locked up. When I became aware of the problem, the screen was displaying the 'attach controller strap and press A & B' screen. It was unresponsive to any front button or controller button pressing. I disconnected the power, waited a few seconds, and turned back on.

    The red light came on, but button pressing on the remote controllers had no effect. The controller wasn't connecting - all four blue lights flash for a few seconds and then go out.

    Pressing the front panel power button causes the red light to turn green, but there is no display on the TV screen (apart from, perhaps, some greyish scan lines). As it turns on, the drive aperture light flashes once and the drive sounds as though it goes through its initialization (a whirring noise). Also, there is no sound from the audio. However, the TV does recognise that a video signal is present - it tells me that a 480p signal is detected (I'm using the optional Hi res video cable). However, no button pushes on the controllers have any effect. Attempting to re-synch a controller appears to have no effect.

    Pressing, and holding, the front panel power switch does cause the power light to go red again.

    Powering up with the reset button held down doesn't appear to do anything.

    Other than this, there is very little sign of life from my Wii. Ah, the wireless point in my router does detect that the Wii Wi-fi is active.

    I have dismantled the Wii, and the voltages identified on the test points are present (1V, 1.65V, 3.3V etc).

    Is my Wii completely defunct, or is it recoverable? Is there anything I can do to get it functioning again?

  2. #2
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    Thank you for such a great description of your problem and the things you have done thus far.

    This could be a bluetooth issue.

    Does the Wiimote power button allow you to power the Wii up to the green light?
    Not really doing much Wii stuff these days.

  3. 1 User Says Thank You Tealc For This Useful Post


  4. #3
    New Member
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Tealc View Post
    This could be a bluetooth issue.
    Would a bluetooth problem stop the video (and audio?) from functioning?

    Can I detect, or test for, the Wii bluetooth signal from a mobile phone or computer bluetooth interface?

    Ah, the other thing I should have mentioned is that I've tried with the original composite video cable, and still get no meaningful output on the screen.

    Something else that I've just thought to try - I get a ping response from the Wii. I presume that this isn't handled by the Wi-fi module, and that it suggest the CPU is actually functioning to support the TCP/IP stack? Is there anything else I can do over the wireless lan to identify to what extent the Wii is functioning?

    Does the Wiimote power button allow you to power the Wii up to the green light?
    No, no buttons on the Wiimote have any effect. I cannot power up or down from the Wiimote. Does the Wiimote have to be synchronised for the power button to work?

    The other thing which may, or may not, be relevant ... the aluminium heatsink becomes too hot to hold after about five minutes powered on ... this is with the pcb out of the case, and no fan operational. Is this normal, or does it indicate an overheating problem? I've never been aware of any artifacts on the display, as others have described when the GPU overheats.
    Last edited by PeteBell; 07-04-2010 at 05:12 AM.

  5. #4
    Member
    Join Date
    Jan 2009
    Posts
    2,692
    Thanks
    254
    Thanked 396 Times in 369 Posts
    defective blue-tooth module will cause black screen ai power on, and no wiimote LED light, either. perhaps, u cannot turn on the Wii with wiimote (ie. by pressing the power button on wiimote), in this case.
    i wish u hv kept the sync'ed wiimote without any change.
    sounds too hot your Wii heatsink, should get the fan on.

  6. 1 User Says Thank You billyhome For This Useful Post


  7. #5
    Retired WiiHacks Staff Krafter's Avatar
    Join Date
    Dec 2009
    Posts
    4,426
    Thanks
    460
    Thanked 1,093 Times in 857 Posts
    Blog Entries
    5
    A bad bluetooth module is a common problem and can be replaced. it sounds like you are handy with things like this so you should be able to replace it yourself easily enough. You can find a replacement on eBay pretty cheap.

  8. 1 User Says Thank You Krafter For This Useful Post


  9. #6
    New Member
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Okay, thanks for the help, everyone. With your pointers, and more research on the net, I'm pretty well convinced that it is the bluetooth module which has failed.

    I wonder why the firmware isn't written to recover from a bluetooth failure - surely it wouldn't be too difficult for the boot sequence to continue and report the fault on screen???

    My next issue is finding a new bluetooth module from a reliable source - most sellers on the web seem to want payment by paypal. Unfortunately paypal have blocked my account - they won't let me close my old UK account because I'm now living Philippines. They won't let me open a new account from Philippines because I still have an active account in UK.

  10. #7
    WiiHacks Staff
    Only Site Donators Can PM Staff

    Junior Moderator
    Bliepo's Avatar
    Join Date
    Nov 2009
    Location
    On your harddrive (file name: Bliepo.crazy)
    Posts
    1,583
    Thanks
    241
    Thanked 391 Times in 312 Posts
    Blog Entries
    4
    Quote Originally Posted by PeteBell View Post
    (...)I wonder why the firmware isn't written to recover from a bluetooth failure - surely it wouldn't be too difficult for the boot sequence to continue and report the fault on screen???(...)
    It wouldn't be hard at all, but nintendo just wants you to make them fix it, so they can make some money out of it. They don want you to fix it yourself :P
    Awesome sig picture does not work
    Brick Prevention- Things you should never do | Ignoring advice and bricking | Be a jedi, donate
    Guide: Softmod ANY wii | How to post a system check | Loading and Playing Wii Backup Games from USB HDD (softmod only)
    System Menu X (IOS150, E) | HBC 1.08 (IOS58) | bootmii/boot2v4 | priiloader 0.7 | cIOSX rev21d2x_v6 (main base IOS 57) | cIOS 223 (IOS 37 + 38 merged) | USB Loader GX 2.2

  11. #8
    New Member
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Okay, my Wii is up and running again I found someone who knows how to re-program the PIC on the bluetooth module.

    So, most of these bluetooth failures are actually just the PIC code becoming corrupted.

  12. #9
    Junior Member
    Join Date
    Dec 2009
    Location
    England
    Posts
    1,304
    Thanks
    7
    Thanked 320 Times in 240 Posts
    Blog Entries
    2
    Ill check that out, pretty sure there was only the broadcom bluetooth chip in there, but will double check and reprogram one if theres a pic or some other epprom in there to test your theory.
    Last edited by Bad_Ad84; 07-07-2010 at 04:23 AM.

  13. #10
    New Member
    Join Date
    Jun 2010
    Posts
    11
    Thanks
    4
    Thanked 0 Times in 0 Posts
    I didn't get a close look, but there were at least two devices under the metal shield. The one which was being programmed looked like an 8-pin smd. The guy was using PonyProg2000, under Windows, through what looked like a home built interface.

    What the guy didn't seem to have worked out is that it is possible to remove, and re-install, the bluetooth module with a little dexterity and a thin blade (a small jeweler's screwdriver will do), with no more dismantling other than removing the front panel from the Wii.
    Last edited by PeteBell; 07-07-2010 at 06:20 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •