Results 1 to 6 of 6

Thread: My first BRICK! Need some help...

  1. #1
    Junior Member
    Join Date
    Apr 2009
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy My first BRICK! Need some help...

    Ok, I bought a Wii off ebay last week that was described as being bricked.

    The guy had no idea what firmware was on it or if any homebrew attempts had been made (useful, yep?)

    When I turn the Wii on, I get a black screen. With the gamecube pad (port 4) and all directions pressed the recovery screen DOES NOT show up (I made sure by fitting a switch to press the D-pad AND tested the pad on my other Wii)

    I've also tried holding reset 'just in case' they guy had Priiloader on - nope.

    So now I have wired up my infectus to the NAND and dumped the 528Mb image from flash. From what I can tell by comparing the first 17Kb to another Wii NAND I have it has the exploitable Boot1b (My other Wii has Boot1c)

    To cut a long story short I'm trying to flash a NAND backup (blocks 0-7) with Bootmii boot2. Erasing & flashing is fine (XavBox) but comparing fails...

    GROUND BOUNCE - When I read back the same 17Kb I have programmed, I can see the Infectus has inserted "FF" in random places and moves the code's offset. This has been bugging me for 3 days now.

    Has anyone got a proven way of eliminating this? I've read about wrapping Data lines with a GND line, but this seems a bit lengthy to do.
    I have also heard (and done on xbox's) of the bad flash method for Xbox 360 - has anyone done this with the Wii? If so, can you advise? (Same pinout for external 5v & 3.3v?)

    Sorry for the lengthy post...

  2. #2
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    Speak with Erikie, he's fixed loads of Wiis with his Infectus.

    --> View Profile: erikie
    Not really doing much Wii stuff these days.

  3. #3
    Junior Member
    Join Date
    Apr 2009
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Tealc View Post
    Speak with Erikie, he's fixed loads of Wiis with his Infectus.

    --> View Profile: erikie
    Just have done. He says to extend to WE wire from the infectus (Q) to the NAND & install a 3rd GND wire.

    I'll have a bash at the bad flash method later (completely remove the Wii interfering)

  4. #4
    Retired WiiHacks Staff Tealc's Avatar
    Join Date
    May 2009
    Location
    Sunny Wales, UK
    Posts
    7,152
    Thanks
    502
    Thanked 4,104 Times in 2,453 Posts
    Blog Entries
    1
    Just have done. He says to extend to WE wire from the infectus (Q) to the NAND & install a 3rd GND wire.
    I'd love to say something really intelligent here but sadly I have no clue when it comes to Infectus.
    Not really doing much Wii stuff these days.

  5. #5
    Junior Member
    Join Date
    Apr 2009
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    All I've learnt is by fiddling around with it. Support is useless & as for installation, they never told me to use the included drivers for Xavbox (took me 2 weeks to figure that)

    Worst thing is, when it's installed it still has it's problems. I've spent hours doing the best wiring job in the world & still run into trouble (Wasabus firmware for example - dodgy 'sync' issues)

  6. #6
    New Member erikie's Avatar
    Join Date
    Oct 2009
    Location
    Netherlands
    Posts
    524
    Thanks
    8
    Thanked 170 Times in 141 Posts
    Blog Entries
    2
    He man, isn't it fun to figure things out yourself? I think it is
    It gives a better feeling when you finally get something working that way
    However you will revive this wii again I am sure about it
    Also I like the infectus nand flasher 1.03 software (amoxiflash for dot net)
    It is not the quickest version but for injecting bootmii it works pretty well.
    Just had to install the libusb filter and the infectus drivers to get it to work
    If you think I helped you please click the little thanks button
    Send me a PM if you have any questions regarding unbricking with infectus mod chip or post a message in here http://www.wiihacks.com/bricked-wii-...installed.html

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •