Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Disk reading Errors (but drive is fine) Possible ios conflicts

  1. #1
    New Member
    Join Date
    Jul 2009
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Disk reading Errors (but drive is fine) Possible ios conflicts

    Hello fellow Wii Owners/Hackers.

    My Google FU has completely failed me on this one, so i'm reaching out for help.

    In an effort to give you as much infomation to help you help me solve my current issue, please prepare for a wall of text:

    My Wii is a Day 1 Wii, that has been hacked since the initial release of the Twilight hack way back in the day. Over the years, it's been further hacked, updated, etc etc, up until today.

    Over that period, Obviously back then, disk based backups were the order of the day, so eventually installed dark corps, So they would run from the disk channel etc, and over time moved to USB loaders and Neogamma for gamecube backups, with the cmios and what not. And copying the games from the Disks to the hard drive worked a treat, so moved onto a fully USB loaded world.

    Now however, Something has gone wrong. I've moved to a new bigger HD, and am now using Fat, with 32kb cluster size, with a view to move to an emulated nand, and USB gamecube loading etc, and thought while I was at it, I would copy all my games still on disks (my originals, and other backups I did not have room for on my previous HD) onto the nice new one.

    CFG loader gives me ERROR! (ret = -2) when I try to copy the disk via the + Button.
    Wii flow gives me a disk open error when i try to copy it via that.

    But then discovered, even more worrying, that original disks are no longer read in the disk channel. Booting a Disk from CFG loader and Wiiflow also failed.
    Thinking that my Disk drive had died on me, as I had not used it for a long time, finally tried NeoGamma.

    It booted. An original, a backup, and a multigame Gamecube backup.

    So the drive is fine.

    So now I turn to you guys for help, What could be goin on here? Obviously some kind of conflict going on what with the vast ammount of Ios's, cios's and other wads/mods that have been loaded over the years.

    I Have used modmii to "rehack" my wii. making sure i had all the latest files etc, Still no go.

    To further help you, I tried to run system check, so you could get a view as to whats actually running on my Wii, But that also seems to be failing. About 75% of the way through the Checking for Vulnerablities, it boots me out back to the bootmii menu.

    So, any ideas guys?



    Also, as a Side note, I do, of course, have a bootmii nand backup, from when I first installed bootmii a few years back, But by that point, obviously i had already had quite a few hacks installed. I know that to use Sneek, you hack the Nand open, and delete a lot of the contents. Am I able to use that process to "virginise" my wii, and start over? Im not fussed about savegames etc, just rather start again. I know its been said in the past that you dont need to start over, just re-hack it, but in my case, thats clearly not worked.

  2. #2
    Senior Member
    WiiHacks Staff
    Forum Administrator
    Only Site Donators Can PM Staff
    nightstah's Avatar
    Join Date
    Nov 2009
    Location
    Repatriated to WH
    Posts
    18,449
    Thanks
    1,837
    Thanked 4,307 Times in 3,617 Posts
    Blog Entries
    5
    DarkCorp replaces a vast majority of your IOS with custom ones. As time progresses, a lot of users end up mixing and matching (standard IOS and DarkFail IOS), which renders the Wii fairly useless for loading backups. Still, that doesn't necessarily sound as if that's the ONLY issue going on with your Wii.

    I'm hoping you verified the make/model of your USB drive in terms of compatibility (not that our list is complete by any stretch) and that you properly configured it.

    Simplest suggestion: do a NAND restore and follow the "Softmod ANY Wii" guide. Then verify it works via optical. Then try the USB drive. That should be a basic process of elimination thing. Alternate suggestion: follow that guide right now without the NAND restore.

  3. #3
    New Member
    Join Date
    Jul 2009
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for your reply.

    You do raise a good point about DarkCorp, I know it messes with a lot of things. The USB drive compatibility thing, however, i believe is not relevant in this case, as it loads games fine, just like the old wbfs hard drive. Homebrew apps are also loading fine from it. However, I cannot rip games to the old wbfs hard drive either, which has worked perfectly fine in the past. Plus, None of that would affect Original games running from the Disk Channel. It's like its not even trying to read the disk. I'm guessing neo gamma does things in a different way.

    Also, as mentioned, I re-Ran the ModMii installer, hoping that would overwrite any bizzare ios's that i have managed to install over the years, but without sucess.

    I think the Restore and try again may be the only option for now, although i'm worried that I had darkcorp BEFORE bootmii, which could be a bugger. But i'll give it a go, and report back.

    Cheers

  4. #4
    Senior Member
    WiiHacks Staff
    Forum Administrator
    Only Site Donators Can PM Staff
    nightstah's Avatar
    Join Date
    Nov 2009
    Location
    Repatriated to WH
    Posts
    18,449
    Thanks
    1,837
    Thanked 4,307 Times in 3,617 Posts
    Blog Entries
    5
    The "Softmod ANY Wii" guide can and will overwrite whatever you have. In your case, it'd be MANDATORY to download and install the IOS update mentioned in the guide. They are standard IOS meant for any Wii below 4.3 (if your Wii is 4.3 you still need them as standard IOS need to be where you have DarkFail IOS).

    ModMii is a nice program, but it really isn't flexible for this sort of thing (whereas our guide is). To each his own... if ModMii no-worky, you know what to do.

  5. #5
    New Member
    Join Date
    Jul 2009
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yeah, apologies, that's what I meant at the end, i'll try with your guide.

    Bearing in mind I already have the latest bootmii, priiipoader etc, Could I just grab the ios wads and mass install, as per the guide? Or would you recommend just starting completely fresh?

  6. #6
    Member
    WiiHacks Staff
    Moderator
    IRC AOP
    Only site donators may send a PM to WiiHacks Staff
    llaffer's Avatar
    Join Date
    May 2010
    Posts
    3,329
    Thanks
    365
    Thanked 1,048 Times in 894 Posts
    To know for sure, can you post a syscheck? Depending on how that looks will make your answer "start at chapter 2", or "start at the top". Directions on how to generate and post a syscheck are linked in my signature.

    Click Below for recommended Links


  7. #7
    Senior Member
    WiiHacks Staff
    Forum Administrator
    Only Site Donators Can PM Staff
    nightstah's Avatar
    Join Date
    Nov 2009
    Location
    Repatriated to WH
    Posts
    18,449
    Thanks
    1,837
    Thanked 4,307 Times in 3,617 Posts
    Blog Entries
    5
    He was unable to (at least as stated in initial post):

    Quote Originally Posted by trencej View Post
    To further help you, I tried to run system check, so you could get a view as to whats actually running on my Wii, But that also seems to be failing. About 75% of the way through the Checking for Vulnerablities, it boots me out back to the bootmii menu.

  8. #8
    Member
    WiiHacks Staff
    Moderator
    IRC AOP
    Only site donators may send a PM to WiiHacks Staff
    llaffer's Avatar
    Join Date
    May 2010
    Posts
    3,329
    Thanks
    365
    Thanked 1,048 Times in 894 Posts
    Ahh. I missed that.

    OK. Then can you tell me this when you launch HBC: The version and which IOS it's running under.

    Click Below for recommended Links


  9. #9
    New Member
    Join Date
    Jul 2009
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The homebrew channel is running under IOS 58. And not sure of the actual version number as I'm at work at the moment, But I let it update itself yesterday, so hopefully the latest one.

  10. #10
    Member
    WiiHacks Staff
    Moderator
    IRC AOP
    Only site donators may send a PM to WiiHacks Staff
    llaffer's Avatar
    Join Date
    May 2010
    Posts
    3,329
    Thanks
    365
    Thanked 1,048 Times in 894 Posts
    ok. then it sounds like you are on 1.1.0 running 58, which is what we want to see.

    If that's still the case, then I'm ok with you starting with Chapter 2 and updating files from ModPack.zip, IOS Update.zip (menu to 4.1 if you want -- don't forget priiloader if you do, install it if it isn't installed regardless), Shop Channel to v21 if you want.)

    Click Below for recommended Links


Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •