Results 1 to 2 of 2

Thread: Some new games go to black screen when trying to play.

  1. #1
    New Member
    Join Date
    Jul 2009
    Posts
    16
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Some new games go to black screen when trying to play.

    I have a Wii with Argon D2C chip. I have firmware 3.1U. I have never updated the wii as I was afraid the update would sense the Argon and brick the unit so I always run brick blocker on the ISO before I burn the DVD. The last 2 games I tried Boom Blox Bash Party and Marble Saga: Kororinpa both show the icon in the main wii screen but when I select the wii goes to black screen and shuts off the remote controller but the unit must be unplugged to be shut off as the power button will not shut the unit off. I have thought about doing a softmod but maybe there is another solution. I have also not unabled the wifi to avoid firmware updating as well. Any help will be greatly appreciated.

  2. #2
    Junior Member
    Join Date
    Aug 2009
    Posts
    26
    Thanks
    5
    Thanked 0 Times in 0 Posts
    A lot of newer games won't work with firmware that old,if you brickblock them ,they don't work fullstop. Its not your Argon chip playing up,it's your Wii firmware, I have an Argon in mine and only updated it to 3.2, but I then installed the HBC as well and Neo gamma R4 (thats out of date now as well) ,now the only games that don't work via NG 4 are the really latest ones .3.2 update is nowhere near upto date enough to play latest games so I've got to update that as well,Sports party needs 4.1 update to work properly and several have update their Wii's to this and their Argons run just fine

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •